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Applying Hot Fix 4 for Sage ACT! 2011 SP1
This documentation describes Hot Fix 4 for ACT! 2011 SP1 for the following versions:

• Sage ACT! Pro 2011 SP1

• Sage ACT! Premium 2011 SP1

• Sage ACT!Premium for Web 2011 SP1

Do not apply this hot fix to any other versions or products.

Note:  To determine the version of the product you are using, see the version 
number in the Help About box. After the hot fix has been installed, the version 
number will read “13.1.111.0 Hot Fix 4" depending on the version you originally 
had installed. 

This hot fix applies to all international English locales. 

Who Should Install This Hot Fix?
Sage ACT! hot fixes are cumulative, so hot fix 4 also resolves issues fixed in hot fixes 1 
through 3. If you have already installed hot fixes 1, 2, or 3, you can safely install hot fix 
4. 

Note:  Sage ACT! 2011 SP1 contained a modification to the database (breaking 
schema change) that will affect anyone sharing or syncing a database on 
13.1.0. If you are sharing or syncing a database on 13.1.0 and would like to 
apply this hot fix, ensure you have access to apply the hot fix to all machines 
that can access your data.

This will not affect you if your version of Sage ACT! is 13.1.1 or 13.1.2, or if you 
do not synchronize or share a database with others.

Hot Fix 4 for Sage ACT! version 2011 SP1 may resolve your issues if:

• You see that Microsoft Outlook takes a long time to load when the Sage ACT! 
address book has been added and Exchange Cache mode is disabled.

• You are using a localized version of Sage ACT! and see that umlauts are stripped 
from the content of any email that also contains a graphic.

• You are using synchronization and see that record information is not being 
exchanged correctly when changes are entered to the same record at both the par-
ent and the remote sites during a single cycle.

• You see that attachments with names that exceed 15 characters are stripped from 
email messages received using Sage ACT! email.

• You notice that Keyword search fails to return all appropriate records.

• Your database contains one or more custom entities that include spillover tables 
and the following error displays when running a query on one of those tables: 
“Ambiguous column name ‘EventsID’.

• You edited a template in Sage ACT! Premium for Web and were unable to save the 
template to a public location. 

• You see that attachments with names that exceed 15 characters are stripped from 
email messages sent using Sage ACT! email.
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Who Should Install This Hot Fix?
• You are using a localized version of Sage ACT!, and see that the Maximize button in 
the Keysearch window is unavailable. 

• You are using a German version of Sage ACT! 2011, and see that the word ‘location’ 
is translated incorrectly in the Appointment Activity Send Email invitation.

• You are using Sage ACT! with Microsoft Windows 7 and Microsoft Office 2007, and 
see performance degrade after sending an email to a contact and then creating or 
clearing an activity.

• You are using Microsoft Outlook Integration with Sage ACT! and see performance 
degrade after sending an email to a contact, opening the calendar, and then open-
ing the task list.

• You are using Sage ACT! 2011 Service Pack 1 with Microsoft Word 2007 or 2010 
and notice that the Quick Print function in Word 2007/2010 is disabled.

• You have cleared the Allow history creation for email sent from a user of this data-
base to another user option (Tools>Preferences> Admin), but find that email sent 
to other users incorrectly adds files to the attachments folder.

• You are using Sage ACT! 2011 Service Pack 1 with ACT! Email and see the options 
to attach a file or a photo are unavailable. 

• You are using Sage ACT! Premium for Web and, after using Lookup to find a group 
of records, you see that the Contact Detail page is blank, you are unable to page 
through the Contacts returned in the lookup, and returning to the Contact List view 
causes you to be logged out of the database.

• You are using Sage ACT! Premium for Web and are unable to change Record Cre-
ation options in the Web Client.

• You are using an English language version of Sage ACT!, but the new Data Chart 
properties display French options.

• You are using Sage ACT! with Outlook Integration over Terminal Server and see an 
error if more than one Sage ACT! user is logged in.

• You are using Sage ACT! Premium for Web with Microsoft Outlook integration 
enabled and notice that Sage ACT! is not listed as an available address book in 
Microsoft Outlook.

• You are using Microsoft Office 2007 with a Dutch language version of Sage ACT! 
and see that, when you create a quote from a new opportunity, the Excel portion of 
the quote fails to populate.

• You are using Sage ACT! Premium for Web and see a distorted view when attempt-
ing to customize columns in the Contact List. 

• You have upgraded to Sage ACT! version 13.1, copied the database using File>Save 
Copy, and see unexpected error messages when attempting to set criteria for dupli-
cate checking in the copy of the database. 

• You have upgraded to Sage ACT! version 13.1, copied the database using File>Save 
Copy, and see unexpected error messages when attempting to delete a user from 
Sage ACT! when connected to the database copy. 

• You are using Sage ACT! version 13.1, and have remote databases, you have set up 
Outlook Contact Synchronization and see data inconsistency across Publisher, 
Remote, and Outlook after syncing.

• You are a Sage ACT! user who has upgraded to version 13.1 and is now unable to 
use your Outlook Add-in for ACT!
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Who Should Install This Hot Fix?
The following tables list the areas affected by the hot fixes, the defect number, 
description, and the effect of the hot fix for each defect.

New in Hot Fix 4

Area
Defect 

#
Description What the Fix Does

Microsoft 
Outlook

94215 Microsoft Outlook takes a long 
time to load if the Sage ACT! 
address book has been added and 
Exchange Cache mode is 
disabled.

Enables Outlook to load 
more quickily.

Lookups 95055 After looking up records in Sage 
ACT! Premium for Web, the 
Contact Detail page is blank, 
users are unable to page through 
the Contacts returned in the 
lookup, and accessing any List 
view causes the user to be logged 
out of the database.

Enables records to 
display on the Contact 
Detail page. Users can 
see the Contacts 
returned in the lookup 
and can click on a List 
view without being 
logged out of the 
database.

Email 95078 Localized versions of Sage ACT! 
strip umlauts from the content of 
any email that also contains a 
graphic.

Prevents the umlauts 
from being stripped 
from the email.

Synchronizati
on

95100 Changes applied to the same 
record at both the parent and the 
remote sites during a single cycle 
do not synchronize correctly. 

Enables the record 
information to be 
synchronized correctly.

Email 95102 Attachments with names that 
exceed 15 characters are stripped 
from email messages received 
using Sage ACT! email.

Enables attachments to 
be received correctly.

Search 95219 Keyword search fails to return all 
appropriate records.

Enables all records 
fitting the search 
criteria to be returned.

95263 The following error displays when 
running a query on a customer 
entity that includes spillover 
tables.
“Ambiguous column name 
‘EventsID’."

Enables the query to 
run without error.

Templates 95273 When editing a template in Sage 
ACT! Premium for Web, the 
option to save the template 
anywhere except the local 
computer is not offered.

Enables the user to 
choose where to save 
the edited template.

Email 95330 Attachments with names that 
exceed 15 characters are stripped 
from email messages sent using 
Sage ACT! email.

Enables attachments to 
be sent correctly.

Search 95410 When using a localized version of 
Sage ACT!, the Maximize button 
in the Keysearch window is 
unavailable. 

Activates the Keysearch 
window Maximize 
button.
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Who Should Install This Hot Fix?
Fixed in Hot Fix 3

The following defects were fixed in hot fix 3.

95206 In the German version of Sage 
ACT! 2011, ‘location’ is translated 
incorrectly in the Appointment 
Activity Send Email invitation.

Replaces “Ablageort” 
with the more 
appropriate translation 
“Ort”.

Area
Defect 

#
Description What the Fix Does

Outlook 
Integration

94650 When using Sage ACT! with 
Microsoft Windows 7 and 
Microsoft Office 2007, 
performance degrades after 
sending an email to a contact and 
then creating or clearing an 
activity.

Removes the 
performance 
degradation.

Outlook 
Integration

94653 When using Sage ACT! with 
Microsoft Outlook Integration, 
users see performance degrade 
after sending an email to a 
contact, opening the calendar, 
and then opening the task list.

Removes the 
performance 
degradation.

Office Add-In 94862 The Sage ACT! Office Add-In in 
version 2011 Service Pack 1 
disables the Quick Print function 
in Word 2007/2010.

Enables the Quick Print 
function to work as 
expected.

Email 94872 When the Allow history creation 
for email sent from a user of this 
database to another user option is 
not selected (Tools>Preferences> 
Admin), email sent to other users 
incorrectly adds files to the 
attachments folder.

Enables the feature to 
function as expected.

Email 94894 When using Sage ACT! 2011 
Service Pack 1 with ACT! Email, 
the options to attach a file or a 
photo are unavailable. 

Enables the options to 
attach a file or a photo. 

Web Client 94895 When using Sage ACT! Premium 
for Web, the Change Record 
Creation options are not 
available.

Enables the Change 
Record Creation 
options.

Lookup 95055 After looking up records in Sage 
ACT! Premium for Web, the 
Contact Detail page is blank, 
users are unable to page through 
the Contacts returned in the 
lookup, and accessing any List 
view causes the user to be logged 
out of the database.

Enables the user to 
click on a List view 
without being logged 
out of the database.

Area
Defect 

#
Description What the Fix Does
4 Sage ACT!



Who Should Install This Hot Fix?
Fixed in Hot Fix 2

Sage ACT! hot fixes are cumulative, so hot fix 4 also contains the following fixes 
distributed in hot fix 2. 

Dashboard 95101 When using a non-localized 
version of Sage ACT!, the new 
Data Chart properties display 
French options.

Displays the Data Chart 
properties in English.

Outlook 
Integration 
and Terminal 
Server

95220 When using Sage ACT! Outlook 
Integration with Terminal Server, 
the second and any additional 
users see an 
Act.Outlook.Sync.exe error.

Enables multiple users 
to log in to use Sage 
ACT! Outlook 
Integration with 
Terminal Server without 
generating errors. 

Area
Defect 

#
Description What the Fix Does

Outlook 
Integration

94649 When using Sage ACT! Premium 
for Web with Microsoft Outlook 
integration enabled, Sage ACT! is 
not listed as an available address 
book in Microsoft Outlook.

Enables the Sage ACT! 
address book to 
display.

Opportunity 
Quotes

94651 When using Microsoft Office 2007 
with a Dutch language version of 
Sage ACT! and creating a quote 
from a new opportunity, the Excel 
portion of the quote fails to 
populate.

Enables the Excel 
portion of the quote to 
populate as expected.

Customizing 
the Contact 
List View

94794 You are using Sage ACT! Premium 
for Web and see a distorted view 
when attempting to customize 
columns in the Contact List.

Prevents the distortion 
and enables the 
Contact List view to 
display correctly. 

Area
Defect 

#
Description What the Fix Does
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Who Should Install This Hot Fix?
Fixed in Hot Fix 1

Sage ACT! hot fixes are cumulative, so hot fix 4 also contains the following fixes 
distributed in hot fix 1.

Area
Defect 

#
Description What the Fix Does

Save Copy 94306 Attempting to set criteria for 
duplicate checking in a database 
copied using File>Save Copy 
causes the following error to 
display: “The DELETE statement 
conflicted with the REFERENCE 
constraint 
“SYSTABLEKEY_SYSCOLUMN_TA
BLEID_FK”. The conflict occurred 
in database “(database name),” 
table 
“dbo.TBL_SYSTABLEKEY_SYSCO
LUMN,” column “TABLEKEYID>.” 
The statement has been 
terminated. 

Enables the user to 
successfully specify 
criteria for duplicate 
checking in the copy of 
the database.

Save Copy 94307 Attempting to delete a user from 
a database copied using 
File>Save Copy causes the 
following error to display: “The 
DELETE statement conflicted with 
the REFERENCE constraint 
"LOGONHISTORY_USERID_FK". 
The conflict occurred in database 
"empty_test_SP1", table 
"dbo.TBL_LOGONHISTORY", 
column 'USERID'. 
PRC_DEL_ACCESSOR: ERROR 
OCCURRED ATTEMPTING TO 
DELETE USER RECORD 
TBL_USER. The statement has 
been terminated. 

Enables the user to 
successfully delete 
users from Sage ACT! 
when connected to the 
copy of the database.

Synchronizati
on - Remote 
Databases

94337 When using Sage ACT! version 
13.1 with Outlook Contact Sync 
and remote databases, data 
synchronizes inconsistently. Data 
inconsistency is visible across 
Publisher, Remote, and Outlook.

Enables data to sync 
correctly.

Outlook 94530 32 bit customers who upgrade to 
Sage ACT! v13.1 are unable to 
use any Sage ACT! Outlook Add-
in after installing an application 
that puts that puts registry keys 
into 64 bit mode.

Enables the Sage ACT! 
Outlook Add-ins to 
function successfully.
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Applying Hot Fix 4 for Sage ACT! 2011 SP1
Applying Hot Fix 4 for Sage ACT! 2011 SP1
This hot fix is for version 2011 SP1. Do not apply this hot fix to any other version of 
Sage ACT! To determine the version of the product you are using, see the version 
number in the Help About box. After the hot fix has been installed, the version number 
will read “13.1.111.0 Hot Fix 4".

Apply this hot fix to all machines where Sage ACT! or the Sage ACT! database is 
installed. 

Note:  Changes in this hot fix will not take effect until you have restarted your 
computer.

Applying the Hot Fix 

1. Log on as Administrator.

2. Copy the hot fix to your computer.

3. Close Sage ACT!

4. Close all Microsoft® Office® products (Excel®, Word®, Outlook®, and so on).

5. Double-click the hot fix file.

A progress dialog box appears indicating that the hot fix is being unpacked. Then a 
Disclaimer dialog box appears.

6. Click OK.

A progress indictor appears showing that Sage ACT! is applying updates. Then a 
dialog box appears stating that the hot fix installation is completed.

7. Click OK.

8. Start Sage ACT!

9. From the Help menu, select About.

The version number will read “13.1.111.0 Hot Fix 4".

Changes To Your Installation

Installing the hot fix applies the following files:

• Act9intf.dll

• Act\JavaScript\ContactListView.js 

• Act\JavaScript\Act.Application.js 

• Act\JavaScript\json2.js 

• Act\JavaScript\Rico\prototype.js 

• Act\JavaScript\Rico\ricoCommon.js 

• Act\JavaScript\Rico\ricoeffects.js 

• Act\JavaScript\Rico\ricogridcommon.js 

• Act\JavaScript\Rico\ricolivegrid.js 

• Act\JavaScript\Rico\ricolivegridajax.js 

• Act.Dashboard.DataChart.dll

• Act.Dashboard.DataChart.xml

• Act.Data.Creation.dll
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Applying Hot Fix 4 for Sage ACT! 2011 SP1
• Act.Framework.dll

• Act.Framework.MailMerge.dll

• Act.Framework.Synchronization.dll

• Act.Office.Addins.dll

• Act.Office2007Addin.dll

• ActOutlookAddin.dll

• Act.Outlook.Addin.Shared.dll

• Act.Outlook.Integration

• Act.Outlook.Message.Reader.dll

• Act.Outlook.Service.Desktop.dll

• Act.Outlook.Sync.Common.dll

• Act.Outlook.Sync.exe

• ActReader.exe

• Act.Shared.Diagnostics.DefectLogger.dll

• Act.Shared.Localization.dll

• Act.Shared.Utilities.dll

• Act.Shared.Win32.dll

• Act.Survey.Plugin.dll

• Act.UI.dll

• Act.UI.Companies.Views.dll

• Act.UI.Contacts.Views.dll

• Act.UI.TabPage.dll

• Act.UI.Widgets.dll

• ACT.Web.dll

• Act.Web.Framework.dll

• Act.Web.ServerControls.dll

• ActDiag.exe

• ActEmail.exe

• Actinet2.ame

• ACTOLEDB2.dll

• ActUpdate.config

• Apfw9AB32.dll

• EmailShared.dll

• Interop.Redemption.dll

• ISSetup.dll

• json2.js
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Applying Hot Fix 4 for Sage ACT! 2011 SP1
• Redemption.dll

• Sage ACT! Premium (Web) Outlook Integration.msi

• SecurityCmdLnApp.exe

• Setup.ini.
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